Skip to main content


Some unexpected downtime this evening


!iSurf Support

Hi all!

It's been awhile. I went to do the update to the latest Friendica -rc version and had some issues. Unfortunately this -rc update has some significant database changes, so to roll back I had to restore from a snapshot I took just before attempting the upgrade.

Apologies if this affected you. I believe the next attempt at the -rc (after getting some clarifications around the issues I saw) will require some downtime in order to help it succeed, so I'll try and post an announcement about it.

All appears to be running fine again now.

Enjoy.

No problem, keep up the good work 😀

What happened @Adam Clark ? Do you have enough information to open an issue?

A low memory situation during the DB updates, and I'm not sure things completed properly.

I did get an email stating the DB updates were completed successfully, but I'm not sure I trust that. After the DB updates were done, I couldn't log in to the system and wasn't seeing anything show up as a problem in the logs.

My plan is to do the following next:

- Optimize most of the DB tables, which is running currently
- Enable Friendica debug logs
- Disable the worker cron job
- Shut down nginx, php-fpm, ejabberd
- git update + composer install
- trigger the db updates from command line
- monitor, catch useful logs at this point, etc. Hopefully everything works.

I will have to think a bit about what I'll do if I don't have enough RAM for the DB upgrades, or if the upgrades could be done with with lighter queries or something.

Sounds like a good plan. I had a noticed a memory issue too after switching to rc. There's a problem now with the background image on my login page.

Is there an ongoing memory issue?

Did I see that you had posted about the background issue in @Friendica Support ?

I optimised all tables and it's less frequent now. There it still dome errors messages coming in.

I see your post over on forum.friendi.ca, but on social.isurf.ca I don't have anything in the support forum in the past 6 days. I wonder what might be going on.

i have a noticed something similar, comparing the number of posts on forum.friendi.ca and the ones actually coming in on my node.

I guess it's not an issue with the forum node itself. Probably related the memory issue where posts get dropped, I suspect.

I'll post over a the forum to discussed this in more detail. I will mention you and ask others to check forum posts coming on their nodes.

Just saw you already posted over there. Followed up now.